OLE Error: Unknown COM status code

Voices aren't working properly?

OLE Error: Unknown COM status code

Postby hlizarraga » Sat May 21, 2011 7:57 am

Hi

I've installed the american spanish demo voices which I planned to use with COM SAPI automation.

I'm using Visual FoxPro 9 (Windows XP SP3) and usually with two lines of code, the SAPI 5 engine sintethizes the text. I have no problems with other voices, Loquendo, for example.

Code: Select all
oSAPI = CreateObject('SAPI.SpVoice')
oSAPI.Speak('hello world')


When trying to speak the text, I received an unknown COM error.

My questions are:

Is this error related with the fact that the voices are not licensed? In this case, licensing the voice will solve the error?

Or is lang/environment related? I mean, VFP is not supported?

I plan to use this voices into an embedded device and I like their price and quality.

Thanks in advance
hlizarraga
 
Posts: 1
Joined: Thu May 19, 2011 7:13 pm

Postby AdamW » Mon May 23, 2011 1:36 pm

Licensing the voices will not resolve the issue, as licensing only cause the voices to speak a reminder to license the voices. We do not directly support Foxpro nor have we tested in the past for the purpose of developer support, so it is quite possible that the error (unspecified as it is) is related to the environment. Is it possible that Foxpro supports SAPI 4 only? Cepstral voices only support SAPI 5.
AdamW
 


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 0 guests

cron