Page 1 of 1

changing swift to use sound card other than 0 on linux

PostPosted: Sat Dec 18, 2010 11:26 pm
by sharamun
Having recently deployed Cepstral Amy to my Debian Linux platform, voice, effects and parameters all seem to be working fine but playback always occurs on sound card 0 even when it isn't the default as specified in either /etc/asound.conf or ~/.asoundrc

I didn't see a setting for this in ./swift/etc/swift.xml but maybe I can set it there or use an option or parameter that isn't documented. It seems this should be possible!

Any pointers would be appreciated. Thanks.


PostPosted: Sun Apr 24, 2011 9:10 pm
by sharamun
I found a fairly easy way to do this by appending the following to /etc/modprobe.d/alsa-base

# force usb sound card to load before integrated sound card
options snd-usb-audio index=0
options snd-hda-intel index=1

This may vary depending on your hardware, but this does the trick.

This is for Debian 5.0.6