Page 1 of 1

Installing to pi

PostPosted: Wed Jun 03, 2015 2:09 am
by ucokzeko
Hi guys,

I am having problem when I try to install Cepstral to my Pi
It's running on raspbian as the operating system
The error message that I got was /opt/swift/bin/swift.bin: 1: /opt/swift/bin.swift.bin: Syntax error: ")" unexpected'
I have been trying to find solutions but it seems like no one has this problem
Any help is really appreciated

Thanks

Re: Installing to pi

PostPosted: Fri Jan 20, 2017 2:51 pm
by crazycajun
Has anyone ever gotten this to work or even install on a pi?

I am starting to believe that I have thrown away 30 bucks!

Re: Installing to pi

PostPosted: Sun Jan 22, 2017 1:53 pm
by 4marcus
I also tried to install it on Debian jessie Model 3 Raspberry Pi and failed.
But I got probably one step further: The error message the script is giving sounds like it is looking for bash, but jessie is defaulting to bin/dash.

I updated the scripts in the bin subdirectory of the installer and explicitly pointed to
Code: Select all
#!/bin/bash


Unfortunately, I am not stuck with this error message, which points to some issue with the actual binary compilation. I opened a support ticket...

Code: Select all
Testing the installed swift binary...
/opt/swift/bin/swift -o /dev/null 'hello world'
/opt/swift/bin/swift: line 12: /opt/swift/bin/swift.bin: cannot execute binary file: Exec format error
/opt/swift/bin/swift: line 12: /opt/swift/bin/swift.bin: Success

Installation failed.  Please contact Cepstral LLC by e-mail for further
support, including a transcript of the installation script's output, if
possible.

Re: Installing to pi

PostPosted: Thu Feb 02, 2017 7:12 pm
by crazycajun
4marcus; Have you heard anything from your support ticket? I would love to know, I have still had zero success. Would love to hear from someone who has gotten it to work with a raspberry pi 3

Would be nice if Cepstral would do an example!

CrazyCajun

Re: Installing to pi

PostPosted: Fri Feb 03, 2017 12:53 am
by 4marcus
Hi

I got a nice reply from customer support: the voices downloadable for testing are 386 architecture, so they won't run on ARM on the Pi. There is a English voice for ARM available from customer support, which I have not tried: the voice is English only for now, but I need multiple languages. So I have not installed the voice up to now and cannot confirm that it actually runs..

Marcus